上篇吕维绘图及原理第 1章 AutoCAD 的设计环境本章要求:了解AutoCAD2014绘图基础知识。包括设置绘图环境、配置绘图系统、坐标系及坐标输入、使用命令、文件操作及显示控制方法等:掌握基本绘图命令Line(直线)及编辑命令Erase(擦除)操作:能够用绝对坐标和相对坐标准确绘制三视图及轴测图。1.1AutoCAD环境功能简介中文版AutoCAD2014提供了“草图与注释”、“三维基础”草图与注释V“三维建模”和“AutoCAD经典”四种工作空间。切换工作空间,三维基础只需单击状态栏中“切换工作空间”按钮,在弹出的菜单中三维建模选择相应的命令即可,如图1-1所示。AutoCAD经典系统默认的工作空间是“草图与注释”,如图1-2所示,主要由菜单浏览器、快速访问工具栏、标题栏、菜单栏、功能区选绍将当前工作空间另存为项卡、功能区面板、绘图窗口、三维导航工具、动态观察导航区、0工作空间设置.命令提示窗口、状态栏等组成。下面简要介绍各部分功能。自定义.1.标题栏图1-1工作空间模式标题栏位于窗口的顶部,用于显示当前正在运行的AutoCAD程序图标及当前所绘制的图形文件名及路径名。在第一次启动AutoCAD时,将显示启动创建的图形文件名“Drawingl.dwg”,如图1-2所示。2.菜单浏览器、快速访问工具栏AutoCAD2014界面包含一个菜单浏览器,位于左上角,如图1-2所示。菜单浏览器可以方便的访问不同的项目。快速访问工具栏位于菜单浏览器左侧,包括“新建”、“打开”、“保存”、“放弃”“重做”和“打印”6个常用的工具按钮。用户也可以单击此工具栏最右侧按钮选择设置需要的常用工具。1
1 上篇 二维绘图及原理 第 1 章 AutoCAD 的设计环境 本章要求:了解 AutoCAD2014 绘图基础知识。包括设置绘图环境、配置绘图系统、坐 标系及坐标输入、使用命令、文件操作及显示控制方法等;掌握基本绘图命令 Line(直线) 及编辑命令 Erase(擦除)操作;能够用绝对坐标和相对坐标准确绘制三视图及轴测图。 1.1 AutoCAD 环境功能简介 中文版 AutoCAD2014 提供了“草图与注释”、“三维基础”、 “三维建模”和“AutoCAD 经典”四种工作空间。切换工作空间, 只需单击状态栏中“切换工作空间”按钮 ,在弹出的菜单中 选择相应的命令即可,如图 1-1 所示。 系统默认的工作空间是“草图与注释”,如图 1-2 所示,主 要由菜单浏览器、快速访问工具栏、标题栏、菜单栏、功能区选 项卡、功能区面板、绘图窗口、三维导航工具、动态观察导航区、 命令提示窗口、状态栏等组成。下面简要介绍各部分功能。 1. 标题栏 标题栏位于窗口的顶部,用于显示当前正在运行的 AutoCAD 程序图标及当前所绘制的图形文件名及路径名。在第一次启动 AutoCAD 时,将显 示启动创建的图形文件名“Drawing1.dwg”,如图 1-2 所示。 2. 菜单浏览器、快速访问工具栏 AutoCAD2014 界面包含一个菜单浏览器,位于左上角,如图 1-2 所示。菜单浏览器可以 方便的访问不同的项目。 快速访问工具栏位于菜单浏览器左侧,包括“新建”、“打开”、“保存”、“放弃”、“重做” 和“打印”6 个常用的工具按钮。用户也可以单击此工具栏最右侧按钮 选择设置需要的常 用工具。 图 1-1 工作空间模式
菜单浏览器快速访问工具栏标题栏菜单栏功能区选项卡信息中心GXDrawing1.dtig越入关0G88.98XOF国EE工具m格式(O)帮助(H)-品×件/FM插入口标主(N)(M)S款IP默认插入注释布局参数化视图管理航出插件Autodesk360情选应用小0品十L鱼AOCOO9本福注释块图层特性组实用工具剪贴板直线多段线园RSE其A6品·绘图·修改、DrawinglO[-1确见]二继我框]功能区面板三维导行工具国WCS绘图窗口动态观察导行区Y状态栏X命令提示窗口K技型人布局布局2命令:·敬入命会十口之十国十型巴大意·459.9173,88.17570.0000图1-2AutoCAD2014默认的工作空间3.菜单栏及快捷菜单菜单栏位于标题栏下方,每一项都对应一个下拉菜单,包含AutoCAD所有操作命令。在系统默认状态下,菜单栏是被隐藏的。若启动菜单栏,需要单击快速访问工具栏最右侧按钮目,展开后选择显示菜单栏即可。AutoCAD菜单选项有以下三种形式:(1)菜单项后面带有三角标记,表示选择该菜单项后,会弹出新的子菜单,以供进一步选择。(2)菜单项后面带有省略号“..”,表示选择该菜单项后会弹出一个对话框,以便进一步操作。(3)单独的菜单项。另一种形式的菜单是快捷菜单,当单击鼠标右键时,在光标位置处会弹出(也称弹出式菜单)。快捷菜单提供的命令选项与光标的位置及AutoCAD的当前状态有关。使用它们可以在不启动菜单栏的情况下快速、高效地完成某些操作。2
2 图 1-2 AutoCAD2014 默认的工作空间 3. 菜单栏及快捷菜单 菜单栏位于标题栏下方,每一项都对应一个下拉菜单,包含 AutoCAD 所有操作命令。在 系统默认状态下,菜单栏是被隐藏的。若启动菜单栏,需要单击快速访问工具栏最右侧 按钮 ,展开后选择 即可。 AutoCAD 菜单选项有以下三种形式: (1)菜单项后面带有三角标记 ,表示选择该菜单项后,会弹出新的子菜单,以供进一 步选择。 (2)菜单项后面带有省略号“...”,表示选择该菜单项后会弹出一个对话框,以便进一 步操作。 (3)单独的菜单项。 另一种形式的菜单是快捷菜单,当单击鼠标右键时,在光标位置处会弹出(也称弹出式 菜单)。快捷菜单提供的命令选项与光标的位置及 AutoCAD 的当前状态有关。使用它们可 以在不启动菜单栏的情况下快速、高效地完成某些操作。 菜单浏览器 快速访问工具栏 标题栏 菜单栏 功能区选项卡 功能区面板 信息中心 三维导行工具 动态观察导行区 命令提示窗口 状态栏 绘图窗口
4.功能区选项卡和功能区面板功能区选项卡位于绘图窗口的上方,用于显示与基手任务的工作空间关联的按钮和控件。在AutoCAD2014初始状态下有11个功能选项卡:“默认”、“插入”、“注释”“布局”“参数化”“视图”、“管理”、“输出”、“插件”、“Autodesk360”和“精选应用”。每个选项卡都包含若干个面板,每个面板又包含许多的命令按钮,如图1-2所示。有的面板中没有足够的空间显示所有的按钮,用户可以单击下方的三角按钮一,展开折叠区域,显示其他相关的命令按钮。此外,单击选项卡右侧的按钮,系统会弹出快捷菜单。在快捷菜单中选择最小化为选项卡命令,选项卡区域将最小化为选项卡;选择最小化为面板标题命令,选项卡区域将最小化为面板标题:选择最小化为面板按钮命令,选项卡区域将最小化为面板按钮:若选择循环浏宽所有项命令,连续单击将在以上显示样式之间切换。5.绘图窗口绘图窗口是用户的绘图区域,类似以手工绘图的图纸。用户的所有工作结果都在此窗口中。用户可根据需要设置屏幕上的绘图区大小及背景颜色。背景颜色可以通过下拉菜单【工具】/【选项】中的【显示】选项卡中设置。绘图窗口包含两种绘图环境:模型空间和图纸空间,对应于窗口底部的三个选项卡【模型>、【布局1】【布局2】,缺省情况下是模型空间。在模型空间下,用户可按实际尺寸绘制二维或三维图形。切换至图纸空间时(即【布局1】或【布局2>),用户可以将图纸空间想象成一张图纸,用户可在这张图纸上将模型空间的图样按不同的缩放比例布置在图纸上。6.命令提示窗口命令提示窗口是用户和AutoCAD进行交互的窗口之一。用户用键盘输入的命令、执行过程中的提示以及相关信息都显示在此窗口中。利用命令提示窗口上的滚动条,可以阅读AutoCAD与用户交互的过程,利用F2键可打开或关闭记录这些交流信息的命令提示窗口。7.状态栏状态栏在操作界面的底部。用来显示AutoCAD当前的状态,如左端显示当前光标的坐标,中间依次显示各种功能开关按钮,如图1-3所示,单击可切换其开关状态。右端为状态托盘,包括一些常见的显示工具和注释工具按钮中LeOz十图国右++++T1-快推捕栅正交本动显选注释监视器对允许三维A轴茶捷特批择循福象象格显示示模功能道捕对捕提输入康象/禁止动态UCS隐隐性式踪R象捕环示藏透明度藏线追R踪宽图1-3状态栏各种功能开关AutoCAD定义了常用的控制按钮的快捷键。如表1-1所示。3
3 4. 功能区选项卡和功能区面板 功能区选项卡位于绘图窗口的上方,用于显示与基于任务的工作空间关联的按钮和控 件。在 AutoCAD2014 初始状态下有 11 个功能选项卡:“默认”、“插入”、“注释”、“布局”、 “参数化”、“视图”、“管理”、“输出”、“插件”、“Autodesk360”和“精选应用”。每个选项 卡都包含若干个面板,每个面板又包含许多的命令按钮,如图 1-2 所示。有的面板中没有足 够的空间显示所有的按钮,用户可以单击下方的三角按钮 ,展开折叠区域,显示其他相关 的命令按钮。 此外,单击选项卡右侧的按钮 ,系统会弹出快捷菜单。在快捷菜单中选择 命令,选项卡区域将最小化为选项卡;选择 命令,选项卡区域将最小化为 面板标题;选择 命令,选项卡区域将最小化为面板按钮;若选择 命令,连续单击 将在以上显示样式之间切换。 5. 绘图窗口 绘图窗口是用户的绘图区域,类似手工绘图的图纸。用户的所有工作结果都在此窗口中。 用户可根据需要设置屏幕上的绘图区大小及背景颜色。背景颜色可以通过下拉菜单【工具】 /【选项】中的【显示】选项卡中设置。 绘图窗口包含两种绘图环境:模型空间和图纸空间,对应于窗口底部的三个选项卡〖模 型〗、〖布局 1〗、〖布局 2〗,缺省情况下是模型空间。在模型空间下,用户可按实际尺寸绘制 二维或三维图形。切换至图纸空间时(即〖布局 1〗或〖布局 2〗),用户可以将图纸空间想 象成一张图纸,用户可在这张图纸上将模型空间的图样按不同的缩放比例布置在图纸上。 6. 命令提示窗口 命令提示窗口是用户和 AutoCAD 进行交互的窗口之一。用户用键盘输入的命令、执行过 程中的提示以及相关信息都显示在此窗口中。 利用命令提示窗口上的滚动条,可以阅读 AutoCAD 与用户交互的过程,利用 F2 键可 打开或关闭记录这些交流信息的命令提示窗口。 7. 状态栏 状态栏在操作界面的底部。用来显示 AutoCAD 当前的状态,如左端显示当前光标的坐 标,中间依次显示各种功能开关按钮,如图 1-3 所示,单击可切换其开关状态。右端为状态 托盘,包括一些常见的显示工具和注释工具按钮。 图 1-3 状态栏各种功能开关 AutoCAD 定义了常用的控制按钮的快捷键。如表 1-1 所示。 捕 捉 功 能 栅 格 显 示 正 交 模 式 极 轴 追 踪 对 象 捕 捉 对 象 捕 捉 追 踪 允 许/ 禁 止 动 态UCS 动 态 输 入 显 示/ 隐 藏 线 宽 快 捷 特 性 选 择 循 环 注 释 监 视 器 显 示/ 隐 藏 透 明 度 三 维 对 象 捕 捉 推 断 约 束
表1-1快捷键功能快捷键功能快捷键功能Esc(退出键)空格键或Enter重复执行命令退出正在执行的命令F5F3开关对象捕捉切换轴测图平面F6F7切换坐标显示开关栅格F9F8开关正交开关捕捉F10F11开关极轴追踪开关对象捕提追踪1.2AutoCAD文件操作1.系统启动启动AutoCAD系统,系统以缺省方式创建“Drawingl”,默认的绘图样板文件是Acadiso.dwt(公制,以mm为单位,绘图界限简称“图限”,大小为420×297)2.新建文件启动AutoCAD系统后,执行下拉菜单中【文件】/【新建】,或单击标准工具栏上的按钮,将出现“选择样板”对话框,常用的样板有acad.dwt(英制,以英寸为单位,图限大小为12×9)和acadiso.dwt(公制,以mm为单位,图限的大小为420×297)。依照国内制图标准应选择acadiso.dwt样板。3.保存文件在已有图形的情况下,更换路径或名字,单击【文件】/【另存为】,不更换则单击【文件】/【保存】或单击工具栏上的按钮日。4.打开文件打开已有文件,可单击文件/(打开或单击工具栏上的按。1.3视图显示控制通常在绘图区域以11的比例(即实际尺寸)绘制图形,而计算机显示屏大小是有限的,受计算机硬件的限制。为了便于绘图操作,AutoCAD提供了控制图形显示的功能,这些功能可使图形按用户期望的位置、比例和范围进行显示,便于观察,但不改变图形的实际尺寸,也不影响图形对象间的相对位置关系。1.3.1显示控制操作图形的显示控制可采用两种方式:第一、滚动鼠标滚轮可缩放视图(向上放大,向下缩小):按住滚轮拖动就可平移视图。第二、利用命令Zoom和Pan可缩放和平移视图,1.缩放命令ZoomZoom也称透明命令,可单击“视图”选项卡,并在“二维导航”面板中单击右侧的扩展按钮,可看到有多个命令选项。常用的三个按钮是、上一个和。i(1)窗口缩放。单击口,光标变成十字准线十,在被放大区拾取左上角点,拖动光标,再拾取右下角点,使窗口区域充满整个绘图区,达到局部放大的目的。(2)缩放上一个。单击上一个,恢复上一次缩放状态。4
4 表 1-1 快捷键功能 快捷键 功能 快捷键 功能 空格键或 Enter 重复执行命令 Esc(退出键) 退出正在执行的命令 F3 开关对象捕捉 F5 切换轴测图平面 F6 切换坐标显示 F7 开关栅格 F8 开关正交 F9 开关捕捉 F10 开关极轴追踪 F11 开关对象捕捉追踪 1.2 AutoCAD 文件操作 1. 系统启动 启动 AutoCAD 系统,系统以缺省方式创建“Drawing1”,默认的绘图样板文 件是 Acadiso.dwt(公制,以 mm 为单位,绘图界限简称“图限”,大小为 420×297)。 2. 新建文件 启动 AutoCAD 系统后,执行下拉菜单中【文件】/【新建】,或单击标准工具 栏上的按钮 ,将出现“选择样板”对话框,常用的样板有 acad.dwt(英制,以英寸为单 位,图限大小为 12×9)和 acadiso.dwt(公制,以 mm 为单位,图限的大小为 420×297)。 依照国内制图标准应选择 acadiso.dwt 样板。 3. 保存文件 在已有图形的情况下,更换路径或名字,单击【文件】/【 另存为】 ,不更换 则单击【文件】/【 保存】或单击工具栏上的按钮 。 4. 打开文件 打开已有文件,可单击【文件】/【 打开】或单击工具栏上的按钮 。 1.3 视图显示控制 通常在绘图区域以 1:1 的比例(即实际尺寸)绘制图形,而计算机显示屏大小是有限的, 受计算机硬件的限制。为了便于绘图操作,AutoCAD 提供了控制图形显示的功能,这些功 能可使图形按用户期望的位置、比例和范围进行显示,便于观察,但不改变图形的实际尺寸, 也不影响图形对象间的相对位置关系。 1.3.1 显示控制操作 图形的显示控制可采用两种方式:第一、滚动鼠标滚轮可缩放视图(向上放大,向下 缩小);按住滚轮拖动就可平移视图。第二、利用命令 Zoom 和 Pan 可缩放和平移视图。 1. 缩放命令 Zoom Zoom 也称透明命令,可单击“视图”选项卡,并在“二维导航”面板中单击 右侧 的扩展按钮 ,可看到有多个命令选项。常用的三个按钮是 、 和 。 (1)窗口缩放。单击 ,光标变成十字准线 ,在被放大区拾取左上角点,拖动光 标,再拾取右下角点,使窗口区域充满整个绘图区,达到局部放大的目的。 (2)缩放上一个。单击 ,恢复上一次缩放状态
(3)实时缩放。单击实时,光标变成α,按住鼠标左键同时上下移动,可实现图形的放大和缩小显示。退出该状态可单击鼠标右键,在快捷菜单上点击【退出】即可。2.平移命令PanPan是指在不改变缩放系数的情况下,观察当前窗口中图形的不同部位,相当于移动图纸。在“二维导航”面板中单击按钮平移,光标变成业,按住鼠标左键上下左右拖动,图形将跟着上下左右移动。退出该状态可单击鼠标右键,在快捷菜单上点击【退出】即可。缩放命令、按钮、菜单及功能见表1-2。表1-2缩放命令、按钮、菜单及功能按钮菜单命令功能W视图/平移/实时使用当前比例漫游图形,拖动鼠标实现操作 panRzoom视图/缩放/实时实时缩放当前图形,拖动鼠标实现操作a视图/缩放/上一个恢复到上一次显示状态previousLa视图/缩放/窗口将画在窗口内的图形放大至整个绘图窗口windowsdynamic视图/缩放/动态可调节窗口的位置或大小连续缩放不同图形区域品scale视图/缩放/比例输入输入新的放大倍数,与图限相乘的到新的显示范围。倍数后加X,则作用于当前显示区,倍数后加XP,则作用于布局中的浮动视窗ia视图/缩放/中心以用户确定的点为中心,以确定的比例因子或高度显示center图形ain将显示放大1倍视图/缩放/放大Qout视图/缩放/缩小将显示缩小1倍Laall视图/缩放/全部取图形界限和当前图形较大者作为显示边界显示图形extends视图/缩放/范围在绘图窗口中尽可能大地显示所有图形T3.重画与重生成在绘图和编辑过程中,屏幕上常常留下对象的拾取标记,这些临时标记并不是图形中的对象,有时会使当前图形画面显得混乱,这时可使用重画与重生成功能清除这些临时标记。重画(Redraw)命令用于刷新屏幕,以消除残留在屏幕上的一些标记点痕迹。在【视图】下拉式菜单中选择【重画】命令即可完成该操作。重新生成(Regen)命令需要系统重新运算,用于刷新当前视窗中的对象。在【视图】下拉式菜单中选择【重生成】命令即可完成该操作。4.显示控制课堂演练单击工具栏上的按钮,打开“C:IProgramFiles/Autodesk/AutoCAD2014\Samplezh-CN\DesignCenter\Landscaping.dwg”,如图1-4所示。运用常用的三个缩放命令、上一个和及平移命令平够,对下图进行显示控制练习,最后单击【视图】/【缩放】/【全部】或单击图标2全或命令行键入“”并回车,再键入“A”并回车,以显示全图。5
5 (3)实时缩放。单击 ,光标变成 ,按住鼠标左键同时上下移动,可实现图形的 放大和缩小显示。退出该状态可单击鼠标右键,在快捷菜单上点击【退出】即可。 2. 平移命令 Pan Pan 是指在不改变缩放系数的情况下,观察当前窗口中图形的不同部位,相当于移动 图纸。在“二维导航”面板中单击按钮 ,光标变成 ,按住鼠标左键上下左右拖动, 图形将跟着上下左右移动。退出该状态可单击鼠标右键,在快捷菜单上点击【退出】即可。 缩放命令、按钮、菜单及功能见表 1-2。 表 1-2 缩放命令、按钮、菜单及功能 按钮 命令 菜单 功能 pan 视图/平移/实时 使用当前比例漫游图形,拖动鼠标实现操作 zoom 视图/缩放/实时 实时缩放当前图形,拖动鼠标实现操作 previous 视图/缩放/上一个 恢复到上一次显示状态 windows 视图/缩放/窗口 将画在窗口内的图形放大至整个绘图窗口 dynamic 视图/缩放/动态 可调节窗口的位置或大小连续缩放不同图形区域 scale 视图/缩放/比例 输入输入新的放大倍数,与图限相乘的到新的显示范围。 倍数后加 X,则作用于当前显示区,倍数后加 XP,则作 用于布局中的浮动视窗 center 视图/缩放/中心 以用户确定的点为中心,以确定的比例因子或高度显示 图形 in 视图/缩放/放大 将显示放大 1 倍 out 视图/缩放/缩小 将显示缩小 1 倍 all 视图/缩放/全部 取图形界限和当前图形较大者作为显示边界显示图形 extends 视图/缩放/范围 在绘图窗口中尽可能大地显示所有图形 3. 重画与重生成 在绘图和编辑过程中,屏幕上常常留下对象的拾取标记,这些临时标记并不是图形中的 对象,有时会使当前图形画面显得混乱,这时可使用重画与重生成功能清除这些临时标记。 重画(Redraw)命令用于刷新屏幕,以消除残留在屏幕上的一些标记点痕迹。在【视 图】下拉式菜单中选择【重画】命令即可完成该操作。 重新生成(Regen)命令需要系统重新运算,用于刷新当前视窗中的对象。在【视图】 下拉式菜单中选择【重生成】命令即可完成该操作。 4. 显示控制课堂演练 单 击 工 具 栏 上 的 按 钮 ,打开“ C:\Program Files\Autodesk\AutoCAD2014\Sample\zh-CN\DesignCenter\Landscaping.dwg”,如图 1-4 所示。 运用常用的三个缩放命令 、 和 及平移命令 ,对下图进行显示 控制练习,最后单击【视图】/【缩放】/【全部】或单击图标 或命令行键入“Z”并回 车,再键入“A”并回车,以显示全图