第9章装配体设计本章要求:了解装配体设计的两种方法,熟悉并理解各种装配约束类型:熟练掌握自底向上的装配设计方法:能够进行零部件的干涉检查:能够生成装配体的爆炸图。9.1装配体设计概述装配体设计有两种设计方法:自下而上设计方法和自上而下设计方法。自下而上设计法是先生成零件并将之插入到装配体设计环境,然后根据设计要求限制各个零件的相对位置,使其构成一个虚拟的部件或机器。自上而下设计法是从装配体中开始设计,可以使用一个零件的几何体来帮助定义另一个零件,或者生成组装零件后才添加的加工特征。可以将布局草图作为设计的开端,定义固定的零件位置、基准面等,然后参考这些定义来设计。当使用以前生成的不在线的零件时,自下而上的设计方案是首选的方法。0下面将介绍装配体中的各相关操作及配合关系,并结合图12-1所示的活塞压气机学习自下而上的装配设计方法。图9-1活塞压气机模型9.2装配体操作装配体操作就是在装配环境中利用装配工具对所插入的零部件进行移动、旋转和配合定位的操控过程,是装配设计中最基本的技能。1.新建装配文件新建装配体与新建零件步骤相同,首先选择装配体模板文件。单击【标准】工具栏上的【新建】图标,将出现“新建SolidWorks文件”对话框,选择【装配体】,单击【确定】按钮,进入装配体窗口并出现“插入零部件”属性管理器,单击【取消】按钮×,如图9-2所示。装配设计的基本操作如下:(1)设定装配体中插入的第一个零件为固定零件:(2)在装配体中插入的其他零件为浮动零件,未指定装配关系时可以随意移动和转动:(3)依托第一个零件,为其他零件添加装配关系。173
173 第 9 章 装配体设计 本章要求:了解装配体设计的两种方法,熟悉并理解各种装配约束类型;熟练掌握自底 向上的装配设计方法;能够进行零部件的干涉检查;能够生成装配体的爆炸图。 9.1 装配体设计概述 装配体设计有两种设计方法:自下而上设计方法和自 上而下设计方法。 自下而上设计法是先生成零件并将之插入到装配体 设计环境,然后根据设计要求限制各个零件的相对位置, 使其构成一个虚拟的部件或机器。 自上而下设计法是从装配体中开始设计,可以使用一 个零件的几何体来帮助定义另一个零件,或者生成组装零 件后才添加的加工特征。可以将布局草图作为设计的开 端,定义固定的零件位置、基准面等,然后参考这些定义 来设计。 当使用以前生成的不在线的零件时,自下而上的设计 方案是首选的方法。 下面将介绍装配体中的各相关操作及配合关系,并结 合图 12-1 所示的活塞压气机学习自下而上的装配设计方 法。 9.2 装配体操作 装配体操作就是在装配环境中利用装配工具对所插入的零部件进行移动、旋转和配合定 位的操控过程,是装配设计中最基本的技能。 1. 新建装配文件 新建装配体与新建零件步骤相同,首先选择装配体模板文件。 单击【标准】工具栏上的【新建】图标 ,将出现“新建 SolidWorks 文件”对话框, 选择【装配体】,单击【确定】按钮,进入装配体窗口并出现“插入零部件”属性管理器, 单击【取消】按钮 ,如图 9-2 所示。 装配设计的基本操作如下: (1)设定装配体中插入的第一个零件为固定零件; (2)在装配体中插入的其他零件为浮动零件,未指定装配关系时可以随意移动和转动; (3)依托第一个零件,为其他零件添加装配关系。 图 9-1 活塞压气机模型
2回X门局公SOLIDWORKSD?达一CO80插入零线性零移动零装配体参考几编辑零配合智能扣示隐新建运材料斗明7部件...部件部件特征何体部件件蓉的零动算例细表部件装配体布局草评估办公室产品国区S8》@an-0..D0.-Y-口装配体2(默认默认显示状态-1装配体工具栏金阿History传感器A注解+装配体中零部件之间的装配关系冷前视基准面冷上视基准面冷右视基准面动画与仿真制作算例原点00配合m.前视模型运动真例图SolidWorksPremium20完全定义在编辑装配体自定义图9-2装配体界面2.插入零部件将一个零部件放入装配体中时,这个零部件文件会与装配体文件链接。零部件出现在装配体中,但零部件的数据还保存在源文件中。对零部件文件所进行的任何改变都会更新装配体。(1)单击【装配体】工具栏上的【插入零部件】图标,或选择菜单【插入】/【零部件】/【现有零件/装配体】命令,出现“插入零部件”属性管理器,如图9-3所示。开始装配体TVX要插入的零件/装配体(P)信息公打开文档(D)选取一零部件进行插入,然后将之放置在图形区域中或者单击确定将之定位在原点处。选项(0)或者使用带有块的布局进行口零脂新能配体时并始命至上而下设计。然后可以从块生成零件。口图形预览(G)生成布局(L)浏览(B)...使成为虚拟(M)图9-3“插入零部件”属性管理器(2)如果在SolidWorks中有已打开的零件或装配体,则可从“打开文档”清单中选择。如果清单中没有想要插入的零件或装配体,则可单击【浏览】,浏览至文件所在位置并选取文件,如图9-4所示。可在图9-4中选择“支座”零件,单击【打开】按钮。174
174 图 9-2 装配体界面 2. 插入零部件 将一个零部件放入装配体中时,这个零部件文件会与装配体文件链接。零部件出现在装 配体中,但零部件的数据还保存在源文件中。对零部件文件所进行的任何改变都会更新装配 体。 (1)单击【装配体】工具栏上的【插入零部件】图标 ,或选择菜单【插入】/【零部件】 /【现有零件/装配体】命令,出现“插入零部件”属性管理器,如图 9-3 所示。 图 9-3 “插入零部件”属性管理器 (2)如果在 SolidWorks 中有已打开的零件或装配体,则可从“打开文档”清单中选择。如 果清单中没有想要插入的零件或装配体,则可单击【浏览】,浏览至文件所在位置并选取文 件,如图 9-4 所示。可在图 9-4 中选择“支座”零件,单击【打开】按钮
XSW打开Psolidworks活塞压气机搜素活塞压气机N组织旺、口O新建文件夹名称POLVr计算机活塞.SLDPRT新加卷(C)活塞压气机.SLDASM本地磁盘(D:)连杆.SLDPRTTOOLS (E)气缸.SLDPRTDATA(F)曲轴.SLDPRTBACKUP (G:)销轴.SLDPRTSWKINGSTON()支座.SLDPRT轴套.SLDPRTAutodesk360m模式还原显示状态-<默认≥显示状态1一配置:默认参考(F)快速过滤器:文件名(N):支座.SLDPRT自定义(*.prt*.asm;*.sldprt*打开取消图9-4“打开”对话框(3)将鼠标移到绘图区,此时鼠标指针变成,单击“插入零部件”属性管理器中的按钮,零件的原点与装配体原点重合,在设计树中“支座”之前标识“固定”,说明该零件是装配体中的固定零件,如图9-5所示。若在设计树上右击零件名,在快捷菜单中选择“浮动”,则可移动或旋转零件。冷前视基准面公上视基准面冷右视基准面原点由(固定)支座<1>00配合图9-5插入的固定零件3.移动和旋转零部件当零部件插入后,如果零件名前有“(一)”的符号,则表示该零件可以被移动和旋转。(1)移动零部件操作。单击【装配体】工具栏上的【移动零部件】图标③,出现属性管理器,如图9-6所示。光标变成于,这时选中零部件就可以自由移动零部件到需要的位置。再次单击图标则退出。175
175 图 9-4 “打开”对话框 (3)将鼠标移到绘图区,此时鼠标指针变成 ,单击“插入零部件”属性管理器中的按钮 ,零件的原点与装配体原点重合,在设计树中“支座”之前标识“固定”,说明该零件是 装配体中的固定零件,如图 9-5 所示。若在设计树上右击零件名,在快捷菜单中选择“浮动”, 则可移动或旋转零件。 图 9-5 插入的固定零件 3. 移动和旋转零部件 当零部件插入后,如果零件名前有“(—)”的符号,则表示该零件可以被移动和旋转。 (1)移动零部件操作。单击【装配体】工具栏上的【移动零部件】图标 ,出现属性管理 器,如图 9-6 所示。光标变成 ,这时选中零部件就可以自由移动零部件到需要的位置。再 次单击图标 则退出
移动(M)公移动(M)MSmartMatesS个小旋转(R)自由拖动?S自由拖动M旋转(R)图9-6“移动零部件”属性管理器图9-7“旋转零部件”属性管理器(2)旋转零部件操作。单击【装配体】工具栏上的【旋转零部件】图标,出现属性管理器,如图9-7所示。光标变成,这时选中零部件,就可以自由旋转零部件到需要的位置。再次单击图标则退出。4.从装配体中删除零部件在图形区域或FeatureManager设计树中单击零部件,按<Delete>键或选择菜单【编辑】/【删除】命令。也可右击零部件并从快捷菜单中选择【删除】命令,这时弹出“确认删除”对话框,单击【是】,则此零件及其所有相关项目(配合、零部件阵列、爆炸步骤等)都会被删除。5.寻找零部件如果装配体中的某个零部件更改了文件名或路径时,则在打开装配体文件时会出现如图9-8所示的提示。可由用户去浏览找到该零部件安装:也可压缩该零件,使系统放弃该零件的安装。SolidWorks无法找到文件H:lsolidworks\活塞压气机\曲轴SLDPRT您是否要亲自意找文件?浏览文件一将从您指定的位置加载文件。→压缩此零部件一将在父装配体中压缩此文件。压缩所有缺失的零部件无法找到所有的文件,当前文档处于打开状态时将被压始回不要再显示(D)图9-8“寻找零部件”对话框9.3配合每个零件在自由空间中都具有6个自由度(3个平移自由度和3个旋转自由度),装配过程中可通过各种配合方式进行零部件自由度的限制。1.添加配合关系SolidWorks中的配合是指零件间的装配关系的方法。1)标准配合方式(1)重合将所选择的面、边线及基准面进行定位以共享同一无限大的面。(2)平行定位所选项目使之保持相同的方向,并且彼此间保持相同的距离。(3)垂直)将所选项目以90°相互垂直定位。(4)【相切】将圆柱面、圆锥面或球面与其他所选项目进行相切定位。(5)【同心】将所选项目定位于共享同一中心轴线。176
176 图 9-6 “移动零部件”属性管理器 图 9-7 “旋转零部件”属性管理器 (2)旋转零部件操作。单击【装配体】工具栏上的【旋转零部件】图标 ,出现属性管理 器,如图 9-7 所示。光标变成 ,这时选中零部件,就可以自由旋转零部件到需要的位置。 再次单击图标 则退出。 4. 从装配体中删除零部件 在图形区域或 FeatureManager 设计树中单击零部件,按<Delete>键或选择菜单【编辑】 /【删除】命令。也可右击零部件并从快捷菜单中选择【删除】命令,这时弹出“确认删除” 对话框,单击【是】,则此零件及其所有相关项目(配合、零部件阵列、爆炸步骤等)都会 被删除。 5. 寻找零部件 如果装配体中的某个零部件更改了文件名或路径时,则在打开装配体文件时会出现如图 9-8 所示的提示。可由用户去浏览找到该零部件安装;也可压缩该零件,使系统放弃该零件 的安装。 图 9-8 “寻找零部件”对话框 9.3 配合 每个零件在自由空间中都具有 6 个自由度(3 个平移自由度和 3 个旋转自由度),装配 过程中可通过各种配合方式进行零部件自由度的限制。 1. 添加配合关系 SolidWorks 中的配合是指零件间的装配关系的方法。 1)标准配合方式 (1)【重合】将所选择的面、边线及基准面进行定位以共享同一无限大的面。 (2)【平行】定位所选项目使之保持相同的方向,并且彼此间保持相同的距离。 (3)【垂直】将所选项目以 90°相互垂直定位。 (4)【相切】将圆柱面、圆锥面或球面与其他所选项目进行相切定位。 (5)【同心】将所选项目定位于共享同一中心轴线
(6)【距离】将所选项目以彼此间指定的距离定位。(7)【角度】将所选项目以彼此间指定的角度定位。2)添加配合的步骤(1)单击【装配体】工具栏上的【配合】图标,或选择菜单【插入】/【配合】命令,出现“配合”属性管理器。(2)激活“要配合实体”列表框,在图形区选择需配合的实体。(3)选择符合要求的配合方式。(4)单击【确定】按钮V,生成添加的配合。3)添加配合的应用(1)新建文件。单击【新建】图标,出现“新建SolidWorks文件”对话框,选择【装配体】,单击【确定】按钮,出现“插入零部件”属性管理器。(2)插入零件。选中“生成新装配体时开始命令”、“图形预览”复选框,单击【浏览】按钮,出现“打开”对话框,如可选择“连杆机构”文件夹中的“支承”零件,单击【打开】按钮,再单击【确定】按钮,在原点插入“支承”零件。同理,再插入“连接杆”零件(支承和连接杆的尺寸如图9-9所示)。单击【保存】按钮日,保存为“连杆机构”,如图9-10所示。G40.图9-9支承和连接杆零件连杆机构(默认默认显示状态由History传感器A注解前视基准面冷上视基准面冷右视基准面原点(固定)支承1>(Default<()连接杆<1>(Default<<De00配合图9-10连杆机构(3)添加配合。单击【配合】图标,出现“配合”属性管理器,激活“要配合的实体”列表框,在图形区选择“支承”孔和“连接杆”孔,系统自动启动同轴心配合,如图9-1所示,单击【确定】按钮,完成同轴心配合。再选取“支承”后端面和“连接杆”前端面,系统自动添加重合配合,如图9-12所示,单击【确定】按钮V,完成重合配合。再单击【确定】按钮√,完成配合。177
177 (6)【距离】将所选项目以彼此间指定的距离定位。 (7)【角度】将所选项目以彼此间指定的角度定位。 2)添加配合的步骤 (1)单击【装配体】工具栏上的【配合】图标 ,或选择菜单【插入】/【配合】命令,出 现“配合”属性管理器。 (2)激活“要配合实体”列表框,在图形区选择需配合的实体。 (3)选择符合要求的配合方式。 (4)单击【确定】按钮 ,生成添加的配合。 3)添加配合的应用 (1)新建文件。单击【新建】图标 ,出现“新建 SolidWorks 文件”对话框,选择【装配 体】,单击【确定】按钮,出现“插入零部件”属性管理器。 (2)插入零件。选中“生成新装配体时开始命令”、“图形预览”复选框,单击【浏览】按 钮,出现“打开”对话框,如可选择“连杆机构”文件夹中的“支承”零件,单击【打开】 按钮,再单击【确定】按钮 ,在原点插入“支承”零件。同理,再插入“连接杆”零件 (支承和连接杆的尺寸如图 9-9 所示)。单击【保存】按钮 ,保存为“连杆机构”,如图 9-10 所示。 图 9-9 支承和连接杆零件 图 9-10 连杆机构 (3)添加配合。单击【配合】图标 ,出现“配合”属性管理器,激活“要配合的实体” 列表框,在图形区选择“支承”孔和“连接杆”孔,系统自动启动同轴心配合,如图 9-11 所示,单击【确定】按钮 ,完成同轴心配合。再选取“支承”后端面和“连接杆”前端 面,系统自动添加重合配合,如图 9-12 所示,单击【确定】按钮 ,完成重合配合。再单 击【确定】按钮 ,完成配合