第1章VisualBasic程序设计概述1.1 Visualbasic 简介程序设计基本概念心Visual Basic的发展VisualBasic的特点1.1.1VisualBasic的发展20世纪60年出现Basic语言:20世纪80年代,TrueBasic、QuickBasic和TurboBasic等;1991年Microsoft公司推出VisualBasicl.0,以可视化工具为界面设计、结构化Basic语言为基础,以事件驱动为运行机制。从1991年的VB1.0至1998年的VB6.0的多次版本升级,功能更强大、完善,应用面更广;2002年正式发布VisualBasic.NET。1.1.2VB的特点例1设计一个滚动文字的广告程序,一行文字在具有背景图案的窗体上、下移动。设计思路:在窗体上使用标签Label对象来存放文字;利用Timer控件来快速触发移动;利用单击按钮来手动触发移动.当一个标签放在窗体上时,标签的左上角坐标(用Left、Top表示)就被指定了。T0,0TopLeft欢迎使用如果改变标签的左上角坐标就可移动标签,即移动文字。例如:Label1.Top=Label1.Top+50可使标签Label1向下移动50单位实现连续移动,可通过时钟对象Timer,在规定的时间间隔执行:Label1.Top =Label 1.Top+50就可使标签Label1连续向下移动。时钟对象的Interval可指定时间间隔,1秒为1000单位。每隔0.2秒移动一次可设置Interval=200程序进一步改进:连续循环移动,首先要能判断出标签是否超出窗体范围。该点在Top方向上的坐标为:窗体的高度Height如果标签的Top>窗体的高度,表示已越出窗体范围,可将标签移到窗体上方,此时标签的Top=?VB功能特点具有基于对象的可视化设计工具心事件驱动的编程机制4提供了易学易用的应用程序集成开发环境"支持结构化程序设计语言"强大的网络、数据库、多媒体功能
第 1 章 Visual Basic 程序设计概述 1.1 Visual basic 简介 ❖ 程序设计基本概念 ❖ Visual Basic 的发展 ❖ Visual Basic 的特点 1.1.1 Visual Basic 的发展 20 世纪 60 年出现 Basic 语言; 20 世纪 80 年代,True Basic、Quick Basic 和 Turbo Basic 等; 1991 年 Microsoft 公司推出 Visual Basic1.0,以可视化工具为界面设计、结构化 Basic 语言为基础,以事件驱动为运行机制。从 1991 年的 VB1.0 至 1998 年的 V B6.0 的多次版本 升级,功能更强大、完善,应用面更广; 2002 年正式发布 Visual Basic.NET。 1.1.2 VB 的特点 例 1 设计一个滚动文字的广告程序,一行文字在具有背景图案的窗体上、下移动。 设计思路: 在窗体上使用标签 Label 对象来存放文字; 利用 Timer 控件来快速触发移动; 利用单击按钮来手动触发移动. 当一个标签放在窗体上时,标签的左上角坐标(用 Left、Top 表示)就被指定了。 如果改变标签的左上角坐标就可移动标签,即移动文字。 例如: Label1.Top=Label1.Top+50 可使标签 Label1 向下移动 50 单位 实现连续移动,可通过时钟对象 Timer,在规定的时间间隔执行: Label1.Top =Label 1.Top+50 就可使标签 Label1 连续向下移动。 时钟对象的 Interval 可指定时间间隔,1 秒为 1000 单位。每隔 0.2 秒移动一次可设置 Interval=200 程序进一步改进: 连续循环移动,首先要能判断出标签是否超出窗体范围。 该点在 Top 方向上的坐标为: 窗体的高度 Height 如果标签的 Top>窗体的高度,表示已越出窗体范围,可将标签移到窗体上方,此时标 签的 Top=? VB 功能特点 ❖ 具有基于对象的可视化设计工具 ❖ 事件驱动的编程机制 ❖ 提供了易学易用的应用程序集成开发环境 ❖ 支持结构化程序设计语言 ❖ 强大的网络、数据库、多媒体功能 欢迎使用 VB Top Left 0,0
完备的帮助功能1.2VB集成开发环境VB系统的安装VB系统的启动VB集成开发环境的使用安装VB6.0有学习版、专业版和企业版三种版本。执行VB6.0的Setup.exe,在安装程序的提示下进行,初学者可采用典型安装方式。VB6.0联机帮助文件使用MSDN文档格式,联机帮助文件不在VB6.0系统盘上,而与VisualStudio产品的帮助集合在两张CD盘上,安装过程中,系统会提示插入MSDN盘。启动启动VB选择开始菜单中的MicrosoftVisualBasic6.0中文版程序。VB6.0窗口列出了VB能够建立的应用程序类型,初学者只要选择默认标准.EXE。单击新建按钮,就可创建该类型的应用程序TE电式具FWEDNaET8VisualBasicR&1clset922oo#学0限HR!心联O国shBeret1.2.1集成开发环境使用国品XNIFL-文件()工程)招式))三行工具手()口的··0843003806dotd口口国工程窗口C工AR工具箱工EL-四口区BE口区LEBE0窗体窗口属性窗口O口吧团窗体布局时的兰中立印窗口R自开始 国货管动#一国15:21TFieEWoft-n1.2.2主窗口1.三种工作模式设计模式界面的设计和代码的编制运行模式运行应用程序
❖ 完备的帮助功能 1.2 VB 集成开发环境 ❖ VB 系统的安装 ❖ VB 系统的启动 ❖ VB 集成开发环境的使用 安装 VB6.0 有学习版、专业版和企业版三种版本。执行 VB6.0 的 Setup.exe,在安装程序的 提示下进行,初学者可采用典型安装方式。 VB6.0 联机帮助文件使用 MSDN 文档格式,联机帮助文件不在 VB6.0 系统盘上,而与 Visual Studio 产品的帮助集合在两张 CD 盘上,安装过程中,系统会提示插入 MSDN 盘。 启动 启动 VB 选择开始菜单中的 Microsoft Visual Basic 6.0 中文版程序。 VB 6.0 窗口列出了 VB 能够建立的应用程序类型,初学者只要选择默认标准.EXE。单击 新建按钮,就可创建该类型的应用程序。 1.2.1 集成开发环境使用 1.2.2 主窗口 1.三种工作模式 设计模式 界面的设计和代码的编制 运行模式 运行应用程序 工具箱 工程窗口 属性窗口 窗体布局 立即窗口 窗体窗口
中断模式暂时中断程序运行,调试程序2.菜单栏包括13个下拉菜单3.工具栏1.2.3窗体设计窗口→窗体是建立VB应用程序的主要部分,一个应用程序至少有一个窗体窗口。◆每个窗体必须有一个唯一的窗体名,默认名为Forml→设计状态的窗体由网格点构成,方便用户对控件的定位,网格点间距可以通过工具选项|通用进入窗体网格设置运行时可通过属性控制窗体的可见性(窗体的网格始终不显示)。代码设计窗口→用来进行代码设计:各种事件过程、过程代码的编写和修改。→打开代码设计窗口的方法:双击窗体、控件资源管理器窗口的”查看代码”对象列表框过程列表框工程1-Poral(Code)口回Comnandlcliek【道用)Comnandl-ForiPrivate SubCommandl_Click()编辑程序代码End SubV山1.2.4属性窗口设置窗体或控件的属性,如颜色、字体、大小等。区屈性-Foral对象列表框Fornl Form口按字母序按分类学属性显示排列方式回外观-Appearance1-3D属性列表框BackColoraHButBorderStvl.2-SizabCaptionFormlFiliColorHD0000FiliStyle -TransFontIransp TrueForeColor8H8000CPalette【(无)Picture无日位置36001HeightCaption返回/设置对象的标题栏中或图属性含义说明粽下面的艾案1.2.5工程管理器窗口→保存一个应用程序所有属性以及组成这个应用程序所有的文件
中断模式 暂时中断程序运行,调试程序 2. 菜单栏 包括 13 个下拉菜单 3. 工具栏 1.2.3 窗体设计窗口 ◆ 窗体是建立 VB 应用程序的主要部分,一个应用程序至少有一个窗体窗口。 ◆ 每个窗体必须有一个唯一的窗体名,默认名为 Form1. ◆ 设计状态的窗体由网格点构成,方便用户对控件的定位,网格点间距可以通过工具| 选项|通用进入窗体网格设置. ◆ 运行时可通过属性控制窗体的可见性(窗体的网格始终不显示)。 代码设计窗口 ◆ 用来进行代码设计:各种事件过程、过程代码的编写和修改。 ◆ 打开代码设计窗口的方法: 双击窗体、控件资源管理器窗口的”查看代码” 1.2.4 属性窗口 设置窗体或控件的属性,如 颜色、字体、大小等。 1.2.5 工程管理器窗口 ◆ 保存一个应用程序所有属性以及组成这个应用程序所有的文件。 对象列表框 过程列表框 编辑程序代码 对象列表框 属性列表框 属性含义说明 属性显示排列方式
4工程文件的扩展名为.VBP,工程文件名显示在工程文件窗口的标题框内中e谷.1.2.6工具箱窗口由21个被绘制成按钮形式的图标构成,利用这些工具,用户可以在窗体上设计各种控件。其中20个控件称为标准控件(注意,指针不是控件,仅用于移动窗体和控件,以及调整它们的大小)。也可通过工程|部件命令将第3方开发的其他控件装入到工具箱。XGeneral指针(Point)图形框(PictureBox)Aabil标签(Label) 文本框(TextBox)框架(Frame)口命令按钮(CommandButton)Pe检查框(CheckBox)单选按钮(OptionButton)组合框(ComboBox)-列表框(List Box)水平滚动条(HScrollBoxBoax)垂直滚动条(VScrollBax)00时钟(Timer)驱动器列表框(DriveListBox)口目目录列表框(DirListBox)文件列表框(FileList Box)DL形状(Shape)直线(Line)口唱图像(Imag,)-数据控制(Data)对象链接与嵌入(OLE)My1.3创建应用程序的过程建立一个应用程序分为以下几步:(1)建立用户界面的对象(2)对象属性的设置(3)对象事件过程及编程(4)保存和运行程序例1.2编写一个人民币与美元兑换的程序。要求:通过输入兑换比率与人民币或美元金额,单击命令按钮显示兑换结果。设计思路:建立用户界面的对象输入使用文本框TextBox;
◆ 工程文件的扩展名为.VBP,工程文件名显示在工程文件窗口的标题框内。 1.2.6 工具箱窗口 由 21 个被绘制成按钮形式的图标构成,利用这些工具,用户可以在窗体上设计各种控 件。其中 20 个控件称为标准控件(注意,指针不是控件,仅用于移动窗体和控件,以及调整 它们的大小)。 也可通过工程|部件命令将第 3 方开发的其他控件装入到工具箱。 1.3 创建应用程序的过程 建立一个应用程序分为以下几步: (1) 建立用户界面的对象 (2) 对象属性的设置 (3) 对象事件过程及编程 (4) 保存和运行程序 例 1.2 编写一个人民币与美元兑换的程序。 要求:通过输入兑换比率与人民币或美元金额,单击命令按钮显示兑换结果。 设计思路: 建立用户界面的对象 输入使用文本框 TextBox; 数据控制(Data) 直线(Line) 文件列表框(FileList Box) 驱动器列表框(DriveListBox) 垂直滚动条(VScrollBox ) 列表框(List Box) 单选按钮(OptionButton) 命令按钮(Command Button) 文本框(Text Box) 对象链接与嵌入(OLE) 图像(Image) 形状(Shape) 目录列表框(DirListBox) 时钟(Timer) 水平滚动条(HScrollBox Box) 组合框(ComboBox) 检查框(CheckBox) 框架(Frame) 标签(Label) 指针(Point) 图形框(Picture Box)
提示使用标签Label:按钮Command的Click事件执行处理命令。1.4使用帮助系统使用MSDNLibrary查阅器通过VB的帮助菜单,选择内容、索引或搜索菜单项?MsDN LibraryVisual studio 6.00文件(E)编辑(E)查看既转(G)帮助(H)温国?金镜活动子集()【(全部集合).目录(索引提索()书签红)(MSDKLibraryVisual Studio6.0快速入门2货需几分钟即可熟悉VisualVisual Basic欢迎进入SNLibrarOBasic 6.?Visual Studio Documentation回VisualBasie文档欢迎阅读Visual新内容Visual Basie起始页做一Basi,千VBa些工作使本文档更易ualBasicaVisual Basie文档描速图的所有新特性。34Visual Basie6.0的新内容于使用,这里的链接是VisuslBasie 6.0入门您查找信息的第站使用Visual Basi套拉示包ualBasio示例应国参考程序Visual Basie甬程序。4-Vi sual Basig 示例员指南是美于付3一Microsoftsual Basic 编程的tory程序员Visual Bas豪势结费单详细的手册。RanosBasic的联机文档和本MSDNI4《部件工具指南》是Lihrary浏器中的助本章小节Visual Basic 6.0一个基于对象的可视化设计工具vb的三种工作模式设计模式、运行模式、中断模式VB程序组成控件和属性设置窗体文件事件代码工程模块文件
提示使用标签 Label; 按钮 Command 的 Click 事件执行处理命令。 1.4 使用帮助系统 使用 MSDN Library 查阅器 通过 VB 的帮助菜单,选择内容、索引或搜索菜单项 本章小节 Visual Basic 6.0 一个基于对象的可视化设计工具 vb 的三种工作模式 设计模式、运行模式、中断模式 VB 程序组成 工程 窗体文件 控件和属性设置 模块文件 事件代码