第6章精确绘图、图案填充及参数化绘图本章要求:掌握精确绘图方法,能用辅助绘图工具提高绘图效率:掌握图案填充命令的应用,能够快速准确地填充图案:了解参数化约束绘制图样理念,能够根据设计要求利用几何约束和尺寸约束绘制出简单图样。6.1精确绘图方法AutoCAD系统提供了多种辅助绘图技术和查询功能,可以有效提高绘图的速度和准确性,准确了解系统的运行状态。6.1.1辅助定位1.GRID(栅格)可在绘图区图限范围内显示一些指定间距的栅格,以作为用户绘图的参考。栅格不是图形的组成部分,因而打印输出图形时并不会打印栅格。命令执行:单击状态栏的按钮或按F7键即可显示栅格。栅格设置:右击状态栏中的按钮,在快捷菜单中单击【设置】,出现“草图设置”对话框,如图6-1所示。可在对话框右上角进行启用栅格和间距大小的设置,若要只显示图限内栅格,则需取消“栅格行为”中“显示超出界限的栅格”复选框的勾选,XA草图设置捕捉和栅格 极轴追踪 对象捕捉 三维对象搏捉 动态输入 快捷特性 选择循环启用捕捉(F9)(S)启用栅格(F7)(G)栅格样式捕捉间距在以下位置显示点栅格:捕捉轴间距P):10二维模型空间()捕捉Y轴间距(C):10块编辑器((K)■图纸/布局0)x轴间距和Y轴间距相等α)栅格间距10极轴间距栅格X轴间距(H)10栅格Y轴间距(I):-极轴距离の):合每条主线之间的栅格数():5捕捉类型栅格行为栅格捕捉()自适应栅格(A)矩形捕提(E)穷诸以小于栅格间距的间距再拆等轴测捕捉(M)显示超出界限的栅格L)PolarSnap (0)■遵循动态UCS(U)选项T)确定取消帮助H)图6-1“草图设置”对话框2.SNAP(捕捉)画可控制光标按指定的间距移动。命令执行:单击状态栏的按钮或按F9键即可启用捕捉。77
77 第 6 章 精确绘图、图案填充及参数化绘图 本章要求:掌握精确绘图方法,能用辅助绘图工具提高绘图效率;掌握图案填充命令的 应用,能够快速准确地填充图案;了解参数化约束绘制图样理念,能够根据设计要求利用几 何约束和尺寸约束绘制出简单图样。 6.1 精确绘图方法 AutoCAD 系统提供了多种辅助绘图技术和查询功能,可以有效提高绘图的速度和准确 性,准确了解系统的运行状态。 6.1.1 辅助定位 1. GRID(栅格) 可在绘图区图限范围内显示一些指定间距的栅格,以作为用户绘图的参考。栅格不是图 形的组成部分,因而打印输出图形时并不会打印栅格。 命令执行:单击状态栏的按钮 或按 F7 键即可显示栅格。 栅格设置:右击状态栏中的按钮 ,在快捷菜单中单击【设置】,出现“草图设置”对 话框,如图 6-1 所示。可在对话框右上角进行启用栅格和间距大小的设置,若要只显示图限 内栅格,则需取消“栅格行为”中“显示超出界限的栅格”复选框的勾选。 图 6-1 “草图设置”对话框 2. SNAP(捕捉) 可控制光标按指定的间距移动。 命令执行:单击状态栏的按钮 或按 F9 键即可启用捕捉
捕捉设置:右击状态栏中的按钮,在快捷菜单中单击【设置】,出现“草图设置”对话框,如图6-1所示。可在对话框左上角进行启用捕捉和间距大小的设置。在左下角“捕捉类型”区可设置捕提类型。(1)栅格捕捉一一矩形捕捉。按指定的矩形栅格间距移动鼠标指针,X和Y方向的间距可相同也可不同。为了便于绘图,捕提一般不启用。如果需要启用的话,设置的间距一般要与栅格间距一致。(2)栅格捕捉一一等轴测捕捉。显示等轴测栅格,光标转换为轴测轴光标,这种模式可以结合ORTHO(正交模式)绘制正等轴测图。(3)PolarSnap。即极轴捕捉,是以设定的间距和极轴方向移动光标。如果选择了“栅格捕捉”,系统就会将捕捉设置成与“栅格”相同的设置,如果选择了“PolarSnap”,系统就会将捕捉设置成与“极轴追踪”相同的设置。3.ORTHO(正交模式)当需要画水平或竖直方向的线时,启动正交模式(将状态栏中按钮按下),可限制光标沿水平或垂直方向移动。此模式下,可用鼠标确定画线的方向(上、下、左、右),然后用键盘键入画线的长度即可。命令执行:单击状态栏的按钮或按F8键即可。6.1.2对象捕提对象捕捉是AutoCAD系统提供的准确定位功能。可以准确拾取图形对象上的几何点,如线段的交点、中点、端点及圆心等。对象捕提可以分为临时对象捕提和运行方式捕捉两种,1.临时对象捕提临时对象捕提需要在运行绘图或编辑命令后才能使用。用户可以从对象捕提工具栏上选取需要的对象捕捉方式启动临时对象捕提(图6-2),也可按Shift+鼠标右键,在快捷菜单中选取需要捕捉方式,也可在命令行中输入捕捉方式的缩写字母。ImX10捕提捕提捕提到平捕提到插捕提4啤捕提捕提到捕捕提捕提到捕提到品捕捕提捕提天代象捕提设置R提到圆到A到到到到捉点节点最近踪点瑞中外延象限切垂足交点上点点长线行线观交点点心点点点图6-2对象捕捉工具栏以作两圆的公切线为例,执行画线命令,单击图标,光标变成“十字”,将光标移到a圆弧切点附近的位置单击,再次单击图标,然后将光标移到b圆弧切点附近的位置单击即可画出两圆公切线,如图6-3所示。1递延切点递延切点图6-3绘制圆的公切线2.运行方式捕捉运行方式捕捉可通过状态栏中对象捕捉按钮设置。系统默认为激活状态。画图过程78
78 捕捉设置:右击状态栏中的按钮 ,在快捷菜单中单击【设置】,出现“草图设置”对 话框,如图 6-1 所示。可在对话框左上角进行启用捕捉和间距大小的设置。在左下角“捕捉 类型”区可设置捕捉类型。 (1)栅格捕捉——矩形捕捉。按指定的矩形栅格间距移动鼠标指针,X 和 Y 方向的间距 可相同也可不同。为了便于绘图,捕捉一般不启用。如果需要启用的话,设置的间距一般要 与栅格间距一致。 (2)栅格捕捉——等轴测捕捉。显示等轴测栅格,光标转换为轴测轴光标,这种模式可以 结合 ORTHO(正交模式)绘制正等轴测图。 (3)PolarSnap。即极轴捕捉,是以设定的间距和极轴方向移动光标。 如果选择了“栅格捕捉”,系统就会将捕捉设置成与“栅格”相同的设置,如果选择了 “PolarSnap”,系统就会将捕捉设置成与“极轴追踪”相同的设置。 3. ORTHO(正交模式) 当需要画水平或竖直方向的线时,启动正交模式(将状态栏中按钮 按下),可限制光 标沿水平或垂直方向移动。此模式下,可用鼠标确定画线的方向(上、下、左、右),然后 用键盘键入画线的长度即可。 命令执行:单击状态栏的按钮 或按 F8 键即可。 6.1.2 对象捕捉 对象捕捉是 AutoCAD 系统提供的准确定位功能。可以准确拾取图形对象上的几何点, 如线段的交点、中点、端点及圆心等。对象捕捉可以分为临时对象捕捉和运行方式捕捉两种。 1. 临时对象捕捉 临时对象捕捉需要在运行绘图或编辑命令后才能使用。用户可以从对象捕捉工具栏上 选取需要的对象捕捉方式启动临时对象捕捉(图 6-2),也可按 Shift+鼠标右键,在快捷菜单 中选取需要捕捉方式,也可在命令行中输入捕捉方式的缩写字母。 图 6-2 对象捕捉工具栏 以作两圆的公切线为例,执行画线命令,单击图标 ,光标变成“十字”,将光标移到 a 圆弧切点附近的位置单击,再次单击图标 ,然后将光标移到 b 圆弧切点附近的位置单击 即可画出两圆公切线,如图 6-3 所示。 图 6-3 绘制圆的公切线 2. 运行方式捕捉 运行方式捕捉可通过状态栏中对象捕捉按钮 设置。系统默认为激活状态。画图过程 临 时 追 踪 点 捕 捉 点 捕 捉 到 端 点 捕 捉 到 中 点 捕 捉 到 交 点 捕 捉 到 外 观 交 点 捕 捉 到 延 长 线 捕 捉 到 圆 心 捕 捉 到 象 限 点 捕 捉 到 切 点 捕 捉 到 垂 足 捕 捉 到 平 行 线 捕 捉 到 插 入 点 捕 捉 到 节 点 捕 捉 到 最 近 点 无 捕 捉 对 象 捕 捉 设 置 a a b b
中系统会自动捕提已设置的捕提点。设置的方法:将鼠标移到状态栏按钮位置,单击鼠标右键,在快捷菜单中单击【设置】,启动草图设置对话框,可以勾选捕捉点前的复选框,设置相应的捕捉模式。注意:在对话框中的捕捉方式不要选择过多,选择几个常用的,如直线的交点、端点、圆心等,若选的过多就会妨碍绘图。另外,只有在执行画图或编辑命令后对象捕捉才起作用。6.1.3对象捕捉追踪对象捕提追踪是系统自动跟踪记忆同一命令操作中光标所经过的捕捉点,从而以其中某一捕捉点的X或Y坐标控制用户所需要选择的定位点。对象捕捉追踪可通过状态栏中对象捕捉追踪按钮设置。系统默认为激活状态。如图6-4所示,在一个矩形(100×100)的中心处画一个半径为25的圆。操作如下:执行矩形命令,画100X100的矩形;右击状态栏按钮,单击【设置】启动草图设置对话框,勾选“捕捉中点”复选框,单击【确定】按钮:执行画圆命令,然后将光标移到矩形底边中点处(光标变成“△”),再将光标移到矩形左边中点处(光标变成“△”),然后将光标移动到矩形中心,此时出现两条相交的追踪线,如图64所示,单击鼠标左键定位圆心,键入半径“25”并回车。4A中点K0中点:<90图6-4利用追踪在矩形中心画圆6.1.4辅助作图在绘图过程中,经常使用辅助作图线帮助定位和构图。AutoCAD提供了构造线和射线两种辅助线以及对象等分等辅助作图方法。1.XLINE(构造线)构造线是一条没有起点和终点的无限延长的直线,常用作画图的参考线。单击绘图面板中绘围按钮,展开后单击图标,AutoCAD提示用户:_xline指定点或[水平(H)/垂直(V)/角度(A)/二等分(B)/偏移(O)]:说明::指定两点绘制构造线:输入一个点,然后AutoCAD提示用户指定一通过点。用户可以不断地指定点来绘制相交于所输入的第一点的多条构造线。·绘制水平的构造线:输入“H”,AutoCAD提示用户指定一通过点,用户可以不断地指定水平构造线的位置来绘制多条水平构造线。·绘制垂直的构造线:输入“V”,AutoCAD提示用户指定一通过点,用户可以不断地指定垂直构造线的位置来绘制多条垂直构造线。·绘制指定角度的构造线:输入“A”,AutoCAD提示用户:“输入参照线角度(O)或[参照(R)]”。用户可以输入一个角度值,然后指定构造线的通过点来绘制与坐标系的X轴成一定角度的构造线。如果用户要绘制与某一直线成一个角度的构造线,则输入“R”,AutoCAD会提示用户选择直线对象并指定构造线与直线的夹角,然后用户可以指定通过点来绘制构造线。79
79 中系统会自动捕捉已设置的捕捉点。 设置的方法:将鼠标移到状态栏按钮 位置,单击鼠标右键,在快捷菜单中单击【设 置】,启动草图设置对话框,可以勾选捕捉点前的复选框,设置相应的捕捉模式。 注意:在对话框中的捕捉方式不要选择过多,选择几个常用的,如直线的交点、端点、 圆心等,若选的过多就会妨碍绘图。另外,只有在执行画图或编辑命令后对象捕捉才起作用。 6.1.3 对象捕捉追踪 对象捕捉追踪是系统自动跟踪记忆同一命令操作中光标所经过的捕捉点,从而以其中某 一捕捉点的 X 或 Y 坐标控制用户所需要选择的定位点。 对象捕捉追踪可通过状态栏中对象捕捉追踪按钮 设置。系统默认为激活状态。 如图 6-4 所示,在一个矩形(100×100)的中心处画一个半径为 25 的圆。操作如下: 执行矩形命令,画 100×100 的矩形;右击状态栏按钮 ,单击【设置】启动草图设置对话 框,勾选“捕捉中点”复选框,单击【确定】按钮;执行画圆命令,然后将光标移到矩形底 边中点处(光标变成“△”),再将光标移到矩形左边中点处(光标变成“△”),然后将光标 移动到矩形中心,此时出现两条相交的追踪线,如图 6-4 所示,单击鼠标左键定位圆心,键 入半径“25”并回车。 图 6-4 利用追踪在矩形中心画圆 6.1.4 辅助作图 在绘图过程中,经常使用辅助作图线帮助定位和构图。AutoCAD 提供了构造线和射线 两种辅助线以及对象等分等辅助作图方法。 1. XLINE(构造线) 构造线是一条没有起点和终点的无限延长的直线,常用作画图的参考线。 单击绘图面板中 按钮,展开后单击图标 ,AutoCAD 提示用户: _xline指定点或[水平(H)/垂直(V)/角度(A)/二等分(B)/偏移(O)]: 说明: 指定两点绘制构造线:输入一个点,然后AutoCAD提示用户指定一通过点。用户可 以不断地指定点来绘制相交于所输入的第一点的多条构造线。 绘制水平的构造线:输入“H”,AutoCAD提示用户指定一通过点,用户可以不断地 指定水平构造线的位置来绘制多条水平构造线。 绘制垂直的构造线:输入“V”,AutoCAD提示用户指定一通过点,用户可以不断地 指定垂直构造线的位置来绘制多条垂直构造线。 绘制指定角度的构造线:输入“A”,AutoCAD提示用户:“输入参照线角度(0)或[参 照(R)]”。用户可以输入一个角度值,然后指定构造线的通过点来绘制与坐标系的 X轴成一定角度的构造线。如果用户要绘制与某一直线成一个角度的构造线,则输 入“R”,AutoCAD会提示用户选择直线对象并指定构造线与直线的夹角,然后用 户可以指定通过点来绘制构造线
·绘制平分角度的构造线:在上面的提示中输入“B”,AutoCAD提示用户依次指定-个角度的顶点、起点和端点,AutoCAD通过用户指定的顶点绘制一条构造线。该构造线平分起点与顶点和端点与顶点两条连线所夹的角度。·绘制平行于直线的构造线:在上面的提示中输入“O”,AutoCAD提示用户“指定偏移距离或[通过(T)]<1.0000>”。如果用户指定了偏移距离,AutoCAD会提示用户选择直线对象并指定构造线画在直线哪一边。如果用户输入“T”,AutoCAD提示用户选择直线对象并指定构造线要通过的点。2.RAY(射线)射线是一种从指定点起,向一个方向无限延长的直线。单击绘图面板中绘图按钮,展开后单击图标,AutoCAD提示用户:_ray指定起点://指定射线的起始点指定通过点://指定射线的通过点,可以连续键入通过点来画起点相同、方向不同的射线,除非按Enter键或Esc键结束命令3.对象等分对象等分包括定数等分和定距等分两种。用作等分的对象可以是直线、圆弧、圆、样条曲线、多段线等,为了使用户能看到等分点,可以重新设置点的样式。单击菜单【格式】/【点样式】,打开【点样式】对话框,从中选择点的样式,如图6-5所示。xA点样式X$U00中中区图6-5点样式对话框1)DIVIDE(定数等分)可在一个对象上按指定的数目等距离放置一些点,这些点也可作为辅助绘图的点。单击绘图面板中绘围按钮,展开后单击图标,AutoCAD提示用户:选择要定数等分的对象://用鼠标在绘图区域选择要放置点的对象输入线段数目或[块(B)]://输入定数等分的数目说明:·DIVIDE命令一次只能等分一个对象。·用户设置的是等分段数,而不是等分点数。如:将一条线段等分5份,则只在其上标记4个点。2)MEASURE(定距等分)可在一个对象上按指定的长度放置一些点,这些点可作为辅助绘图的点。单击绘图面板中绘图按钮,展开后单击图标,AutoCAD提示用户选择要定距等分的对象://用鼠标在绘图区域选择要放置点的对象指定线段长度或[块(B)]://输入定距等分的距离或用鼠标在屏幕上指定两点来确定长度说明:·AutoCAD在放置点或块时,将离选择对象点较近的端点作为起始位置。如果用户用块代替点,那么在放置块的同时其属性被排除。80
80 绘制平分角度的构造线:在上面的提示中输入“B”,AutoCAD提示用户依次指定一 个角度的顶点、起点和端点,AutoCAD通过用户指定的顶点绘制一条构造线。该构 造线平分起点与顶点和端点与顶点两条连线所夹的角度。 绘制平行于直线的构造线:在上面的提示中输入“O”,AutoCAD提示用户“指定偏 移距离或[通过(T)]<1.0000>”。如果用户指定了偏移距离,AutoCAD会提示用户 选择直线对象并指定构造线画在直线哪一边。如果用户输入“T”,AutoCAD提示 用户选择直线对象并指定构造线要通过的点。 2. RAY(射线) 射线是一种从指定点起,向一个方向无限延长的直线。 单击绘图面板中 按钮,展开后单击图标 ,AutoCAD 提示用户: _ray指定起点: //指定射线的起始点 指定通过点: //指定射线的通过点,可以连续键入通过点来画起点相同、方向不同的射线,除非按Enter 键或Esc键结束命令 3. 对象等分 对象等分包括定数等分和定距等分两种。 用作等分的对象可以是直线、圆弧、圆、样条曲线、多段线等,为了使用户能看到等分 点,可以重新设置点的样式。单击菜单【格式】/【点样式】,打开【点样式】对话框,从中 选择点的样式,如图 6-5 所示。 1)DIVIDE(定数等分) 可在一个对象上按指定的数目等距离放置一些点,这些点也可作为辅助绘图的点。 单击绘图面板中 按钮,展开后单击图标 ,AutoCAD提示用户: 选择要定数等分的对象://用鼠标在绘图区域选择要放置点的对象 输入线段数目或[块(B)]://输入定数等分的数目 说明: DIVIDE命令一次只能等分一个对象。 用户设置的是等分段数,而不是等分点数。如:将一条线段等分5份,则只在其上 标记4个点。 2)MEASURE(定距等分) 可在一个对象上按指定的长度放置一些点,这些点可作为辅助绘图的点。 单击绘图面板中 按钮,展开后单击图标 ,AutoCAD提示用户: 选择要定距等分的对象://用鼠标在绘图区域选择要放置点的对象 指定线段长度或[块(B)]://输入定距等分的距离或用鼠标在屏幕上指定两点来确定长度 说明: AutoCAD在放置点或块时,将离选择对象点较近的端点作为起始位置。如果用户用 块代替点,那么在放置块的同时其属性被排除。 图 6-5 点样式对话框
·若对象总长不能被指定间距整除,则选定对象的最后一段小于指定间距数值。·测量闭合的多段线时,AutoCAD将从它们绘制的第一个点处开始。·测量圆时,AutoCAD将从设置为当前捕捉旋转角的角度开始测量。如果捕捉旋转角为零,那么从圆心右侧的圆周点开始测量圆。·MEASURE命令一次只适用于个对象。6.1.5查询AutoCAD提供了查询功能,可以方便用户了解AutoCAD的运行状态,查询图形对象的数据信息,计算距离、面积和质量特性等,是进行计算机辅助设计的重要工具。1.距离查询DIST命令可以测量两点间的直线距离以及该直线与X轴的夹角。选择菜单【工具】/【查询】/【距离】命令,光标变成十字准线,移动光标到图形中A点,再移到B点,如图6-6(a)所示,在命令行的文本窗口中就会出现下面的距离、倾角、X、Y增量。同时,在图形上显示对应的数值,如图6-6(b)所示。Command: DIsT Specify first point: Specify second point:Distance =59.3992,Angle in XY Plane=27,Angle from XYDelta X = 52.8172,Delta Y=27.1774,Delta z= 0.000059.3992P27.1774距离=59.3992端点输入选项·距离(D)52.8172半径(R)(a)(b)图6-6查询两点距离如果输入选项“R”、“A”,也可以相应查询圆弧半径及角度。2.面积查询AREA命令可以测量图形中某封闭区域的面积和周长,并可根据情况增加或减少某部分的面积。选择菜单【工具】/【查询】】【面积】命令,在命令行中出现下列提示:命令:二area指定第一个角点或[对象(O)/加(A)/减(S)]:说明:·指定第一个角点:计算由顺序输入的各个顶点(3个点以上,且位于同一个平行当前用户坐标系的平面内)所围成的多边形的面积和周长。其后续提示为“指定下一个角点或按Enter健全选”,这时选择第二角点,也出现相同的提示;依次选择3个以上角点后回车,显示计算结果。面积=XXX,周长=XXX。如多边形不封闭,则AutoCAD用直线闭合后计算所围成的多边形面积和周长,其周长包括封闭边的长度。·对象(O):计算指定对象的面积和周长,可使用的对象包括圆、椭圆、样条曲线、多段线、正多边形、面域和实体等。如所选对象为圆弧和开式多线段或样条曲线,系统则用直线闭合后进行计算:如所选对象为设置了宽边的多线段,则沿中心线进行计算。81
81 若对象总长不能被指定间距整除,则选定对象的最后一段小于指定间距数值。 测量闭合的多段线时,AutoCAD将从它们绘制的第一个点处开始。 测量圆时,AutoCAD将从设置为当前捕捉旋转角的角度开始测量。如果捕捉旋转角 为零,那么从圆心右侧的圆周点开始测量圆。 MEASURE命令一次只适用于一个对象。 6.1.5 查询 AutoCAD提供了查询功能,可以方便用户了解AutoCAD的运行状态,查询图形对象的数据 信息,计算距离、面积和质量特性等,是进行计算机辅助设计的重要工具。 1. 距离查询 DIST 命令可以测量两点间的直线距离以及该直线与 X 轴的夹角。 选择菜单【工具】/【查询】/【距离】命令,光标变成十字准线,移动光标到图形中 A 点,再移到 B 点,如图 6-6(a)所示,在命令行的文本窗口中就会出现下面的距离、倾角、 X、Y 增量。同时,在图形上显示对应的数值,如图 6-6(b)所示。 (a) (b) 图 6-6 查询两点距离 如果输入选项“R”、“A”,也可以相应查询圆弧半径及角度。 2. 面积查询 AREA 命令可以测量图形中某封闭区域的面积和周长,并可根据情况增加或减少某部分 的面积。 选择菜单【工具】/【查询】/【面积】命令,在命令行中出现下列提示: 命令:_area 指定第一个角点或[对象(O)/加(A)/减(S)]: 说明: 指定第一个角点:计算由顺序输入的各个顶点(3 个点以上,且位于同一个平行当前用 户坐标系的平面内)所围成的多边形的面积和周长。其后续提示为“指定下一个角点 或按 Enter 健全选”,这时选择第二角点,也出现相同的提示;依次选择 3 个以上角 点后回车,显示计算结果。面积=XXX,周长=XXX。如多边形不封闭,则 AutoCAD 用直线闭合后计算所围成的多边形面积和周长,其周长包括封闭边的长度。 对象(O):计算指定对象的面积和周长,可使用的对象包括圆、椭圆、样条曲线、多 段线、正多边形、面域和实体等。如所选对象为圆弧和开式多线段或样条曲线,系统 则用直线闭合后进行计算;如所选对象为设置了宽边的多线段,则沿中心线进行计算