得:d=f=±0.3535,取d=f=-0.3535,因此,斜二测投影的变换矩阵Tα二削10000.35350-0.3535为:T斜二侧=0001000110.2零件工程图设计工程图是表达设计者思想及加工和制造零部件的依据,是进行技术交流的重要文本资料。工程图设计就是利用SolidWorks软件内含的各种视图生成工具及注解工具等,将所创建的三维实体零件和装配体转换为符合工程制图标准的工程图样。10.2.1工程图概述SolidWorks工程图文件中包含两个独立的部分:图纸格式和工程图视图。图纸格式包含工程图图幅的大小、标题栏设置、零件明细表及其定位等。由于图纸格式在工程图文件中相对比较稳定,所以一般先设置或者创建需要的工程图图纸格式。1.新建工程图工程图包含一个或者多个由零件或者装配体生成的视图。在生成工程图之前,必须先保存与它有关的零件或装配体。新建工程图的操作步骤如下。单击【标准】工具栏中的【新建】图标,出现“新建SolidWorks文件”对话框。点选底部的【高级】按钮,出现【模板】选项卡窗口,系统在该窗口列出了零件、装配体及gbao至gba4的工程图模板,选择任一工程图模板(如gba3),单击【确定】按钮,进入工程图的工作界面,如图10-7所示。工程图的工作界面与零件、装配体的工作界面有很大的区别,新增加了【视图布局】工具选项卡、【注解】工具选项卡等。C品?回XDSSOLIDWORKS医国视图布局注解草评估办公室产品网贝XAQa3n.o四T工程图1A注解由图纸1L图纸I自面店0mm欠定义在编辑图纸11:房85.29mm151.94mm202
202 得: d = f = 0.3535 ,取 d = f = −0.3535,因此,斜二测投影的变换矩阵 T斜二侧 为: − − = 0 0 0 1 0 0 1 0 0.3535 0 0.3535 0 1 0 0 0 T斜二侧 10.2 零件工程图设计 工程图是表达设计者思想及加工和制造零部件的依据,是进行技术交流的重要文本资 料。工程图设计就是利用 SolidWorks 软件内含的各种视图生成工具及注解工具等,将所创 建的三维实体零件和装配体转换为符合工程制图标准的工程图样。 10.2.1 工程图概述 SolidWorks 工程图文件中包含两个独立的部分:图纸格式和工程图视图。图纸格式包 含工程图图幅的大小、标题栏设置、零件明细表及其定位等。由于图纸格式在工程图文件中 相对比较稳定,所以一般先设置或者创建需要的工程图图纸格式。 1. 新建工程图 工程图包含一个或者多个由零件或者装配体生成的视图。在生成工程图之前,必须先保 存与它有关的零件或装配体。新建工程图的操作步骤如下。 单击【标准】工具栏中的【新建】图标 ,出现“新建 SolidWorks 文件”对话框。点 选底部的【高级】按钮,出现【模板】选项卡窗口,系统在该窗口列出了零件、装配体及 gb_a0 至 gb_a4 的工程图模板,选择任一工程图模板(如 gb_a3),单击【确定】按钮, 进入 工程图的工作界面,如图 10-7 所示。工程图的工作界面与零件、装配体的工作界面有很大 的区别,新增加了【视图布局】工具选项卡、【注解】工具选项卡等
图10-7工程图工作界面2.建立多张工程图在需要的情况下,可以在一个工程图文件中包含多张XSolidWorks工程图纸。在图纸的空白处单击鼠标右键,从快捷菜单中无法找到图纸格式。选择【添加图纸】命令,会出现“无法找到图纸格式”对话框,如图10-8所示,单击【确定】按钮,会出现【图纸确定格式/大小】对话框,如图10-9所示。选择一标准图纸格式(如A3),单击【确定】按钮,就会在文件中新增加图10-8无法找到图纸格张图纸,如图10-10所示。X图纸格式/大小标准图纸大小(A)预览:◆只显示标准格式(F)A1 (GB)A2 (GB)A3 (GB)A4 (GB)a3 -gb.slddrt浏览B..宽度:420.00mm◆显示图纸格式(D)高度:297.00mm自定义图纸大小(M宽度W:高度(H):确定(O)取消(C)帮助(H)图10-9图纸格式/大小图3.定义用户图纸格式单击标签可以激SolidWorks2014提供了各国的从A0至A4的标活不同图纸准图纸格式,每一种图纸格式都包含了确定的图框与标题栏,用户可以根据需要选用。在选择图纸后,A图纸1图纸2在右侧的“预览”栏中可以查看图纸的预览效果及高度、宽度等,如图10-9所示。图10-10建立多张工程图但在实际应用中,各行业的图纸格式往往不统一,所以用户需要设计符合本行业要求的图纸格式并存工程图1储,便于以后应用。下面创建一个“A3横向”图纸格式。A注解由图纸11)创建工程图文件图纸(图纸1)单击【标准】工具栏中的【新建】图标,弹出“新显示网格线(A)建SoildWorks文件”对话框。单击【高级】按钮,对话图纸格式(B框切换到模板选项窗口,选择gb_a3模板,单击【确定】添加图纸.(C)按钮,进入gb_a3工程图界面。在FeatureManager设计E复制(D)树中右击“图纸1”,并在快捷菜单中选【编辑图纸格式】,X册除(E)如图10-11所示。图10-11编辑图纸格式2)绘制图框203
203 图 10-7 工程图工作界面 2. 建立多张工程图 在需要的情况下,可以在一个工程图文件中包含多张 工程图纸。在图纸的空白处单击鼠标右键,从快捷菜单中 选择【添加图纸】命令,会出现“无法找到图纸格式”对 话框,如图 10-8 所示,单击【确定】按钮,会出现【图纸 格式/大小】对话框,如图 10-9 所示。选择一标准图纸格 式(如 A3),单击【确定】按钮,就会在文件中新增加一 张图纸,如图 10-10 所示。 图 10-9 图纸格式/大小 3. 定义用户图纸格式 SolidWorks2014提供了各国的从A0 至A4 的标 准图纸格式,每一种图纸格式都包含了确定的图框 与标题栏,用户可以根据需要选用。在选择图纸后, 在右侧的“预览”栏中可以查看图纸的预览效果及 高度、宽度等,如图 10-9 所示。 但在实际应用中,各行业的图纸格式往往不统 一,所以用户需要设计符合本行业要求的图纸格式并存 储,便于以后应用。下面创建一个“A3 横向”图纸格式。 1)创建工程图文件 单击【标准】工具栏中的【新建】图标 ,弹出“新 建 SoildWorks 文件”对话框。单击【高级】按钮,对话 框切换到模板选项窗口,选择 gb_a3 模板,单击【确定】 按钮,进入 gb_a3 工程图界面。在 FeatureManager 设计 树中右击“图纸 1”,并在快捷菜单中选【编辑图纸格式】, 如图 10-11 所示。 2)绘制图框 单击标签可以激 活不同图纸 图 10-10 建立多张工程图 图 10-8 无法找到图纸格 式 图 10-11 编辑图纸格式
(1)框选并删除原有的图纸格式及文字。单击草图工具中【矩形】图标,在视图中绘制一个图框,单击图框左下角点,此时系统弹出图10-12所示的“点”属性管理器,在“参数”的X、Y一栏中分别输入“25.00”和“5.00”,然后单击【固定】按钮,将左下角点固定。同样,将右上角端点固定在坐标(415,292)处。现有几何关系固定340完全定义添加几何关系必固定(F)选项(O)10舒数25.005.00+图10-12固定图框角点(2)连选四条图框线,单击【线型】工具栏中的“线粗”图标,定义四条框线为粗线,如图10-13所示。默认0.18mm0.25mm0.35mm0.5mm0.7mm1mm1.4mm图10-13设置线宽4)绘制标题栏(1)按要求绘制标题栏中相应的直线,并使用几何关系、尺寸确定直线的位置,如图10-14所示。130653512-1228oo8图10-14标题栏(2)选择菜单【视图】/【隐藏/显示注解】命令,当鼠标指针变为时,依次选择各尺寸,被选中的尺寸呈浅灰色显示,单击鼠标右键,在弹出的快捷菜单中单击图标,则所204
204 (1)框选并删除原有的图纸格式及文字。单击草图工具中【矩形】图标 ,在视图中 绘制一个图框,单击图框左下角点,此时系统弹出图 10-12 所示的“点”属性管理器,在“参 数”的 X、Y 一栏中分别输入“25.00”和“5.00”,然后单击【固定】按钮 ,将左下角点 固定。 同样,将右上角端点固定在坐标(415,292)处。 图 10-12 固定图框角点 (2)连选四条图框线,单击【线型】工具栏中的“线粗”图标 ,定义四条框线为粗 线,如图 10-13 所示。 图 10-13 设置线宽 4)绘制标题栏 (1)按要求绘制标题栏中相应的直线,并使用几何关系、尺寸确定直线的位置,如图 10-14 所示。 图 10-14 标题栏 (2)选择菜单【视图】/【隐藏/显示注解】命令,当鼠标指针变为 时,依次选择各 尺寸,被选中的尺寸呈浅灰色显示,单击鼠标右键,在弹出的快捷菜单中单击图标 ,则所
有尺寸均被隐藏。5)注释(1)一般注释。单击【注解】工具栏中的【注释】图标A,弹出“注释”属性管理器。然后在标题栏中注写不带括弧的文字,如图10-15所示,拖动文字调整其位置,这些文字一般是不变的。比例(图名)(图号)件数制图材料(日期)重量描图(日期)(单位)审核(日期)图10-15添加文字的标题栏样式S)(2)链接图纸文件的属性。单击【注解】工具行栏中的【注释】图标A,在标题栏“比例”右侧栏中无格式化单击来定位输入点,如图10-16所示,在“注释”属文字格式5国汉仪长仿末体000性管理器中单击【链接到属性】按钮,出现如图网比钢10-17所示的对话框,在【当前文件】属性的下拉列0.00克件数表中选择“SW-图纸比例(SheetScale)”,单击【确eAeE重量定】按钮,再单击属性面板中按钮√,注释显示图纸链接型压性比例,如图10-18所示。同理,可在“图名”处链接德用文档字体儿工程图名“SW-文件名称(FileName)”。则“图名”图10-16链接属性处显示“工程图1”X链接到尾性使用来自此项的自定义属性当前文件注解所附加于的视图的模型图纸厘性中所指定视图中模型注解所附加于的季部件比例1: 1口切制列表属性件数sw图纸比例(sheetScal文件屋佳(F长日期重量材料团显示时间确定双消图10-17“链接到属性”对话框图10-18链接图纸比例(3)链接零件模型的属性。单击【注解】工具栏中的【注释】图标A,在标题栏“重量”右侧栏中单击来定位输入点,在“注释”属性管理器中单击【链接到属性】按钮,出现如图10-17所示的“链接到属性”对话框,选取【图纸属性中所指定视图的模型】单选按钮,再单击【文件属性】按钮,弹出“摘要信息”对话框,如图10-19所示。在对话框中单击【编辑清单】按钮,并在出现的“编辑自定义属性清单”对话框中键入“重量”,单击【确定】按钮。再在“摘要信息”对话框中单击“属性名称”最后一行,展开下拉列表选取“重量”,单击【确定】按钮完成“重量”信息的添加。此时单击图10-17所示的【文件属性】按钮左侧的下拉框选择“重量”,单击【确定】按钮完成“重量”属性的链接。同理可205
205 有尺寸均被隐藏。 5)注释 (1)一般注释。单击【注解】工具栏中的【注释】图标 ,弹出“注释”属性管理器。 然后在标题栏中注写不带括弧的文字,如图 10-15 所示,拖动文字调整其位置,这些文字一 般是不变的。 图 10-15 添加文字的标题栏 (2)链接图纸文件的属性。单击【注解】工具 栏中的【注释】图标 ,在标题栏“比例”右侧栏中 单击来定位输入点,如图 10-16 所示,在“注释”属 性管理器中单击【链接到属性】按钮 ,出现如图 10-17 所示的对话框,在【当前文件】属性的下拉列 表中选择“SW-图纸比例(Sheet Scale)”,单击【确 定】按钮,再单击属性面板中按钮 ,注释显示图纸 比例,如图 10-18 所示。同理,可在“图名”处链接 工程图名“SW-文件名称(File Name)”。 则“图名” 处显示“工程图 1” 图 10-17 “链接到属性”对话框 图 10-18 链接图纸比例 (3)链接零件模型的属性。单击【注解】工具栏中的【注释】图标 ,在标题栏“重 量”右侧栏中单击来定位输入点,在“注释”属性管理器中单击【链接到属性】按钮 , 出现如图 10-17 所示的“链接到属性”对话框,选取【图纸属性中所指定视图的模型】单选 按钮,再单击【文件属性】按钮,弹出“摘要信息”对话框,如图 10-19 所示。在对话框中 单击【编辑清单】按钮,并在出现的“编辑自定义属性清单”对话框中键入“重量”,单击 【确定】按钮。再在“摘要信息”对话框中单击“属性名称”最后一行,展开下拉列表选取 “重量”,单击【确定】按钮完成“重量”信息的添加。此时单击图 10-17 所示的【文件属 性】按钮左侧的下拉框选择“重量”,单击【确定】按钮完成“重量”属性的链接。同理可 图 10-16 链接属性
建立“件数”、“材料”、“图号”、“制图”等属性链接。链接属性后的标题栏如图10-20所示。回x携要信息自定义 配置特定摘要材料明细表数量删除(D)-无编辑清单(日4评估的值属性名称美型数值/文字表达16校对文字17审定文字18阶段标记s文字x编辑自定义属性清单19阶段标记A文字20阶段标记B、文字重量确定21誉代文字Desc22图幅文字intn、取消零件号23版本文字数量24鲁注文字修订添加名称Material25文字Weiaht删除代号26文字光洁度27共张StockSize文字上移测量单位28第张文字成本·总成本29键入新属性:车下移确定取消帮助(H)图10-19在编辑清单和摘要信息中添加重量属性比例 : 1工程图1SERSHEETP号件数SPAPSHEET数室制图SPAPSHEETSHEETRPSHEEPAPSHEET籽猎图申核图10-20链接了属性的标题栏注意:上述所链接的零件属性必须在零件模型文件属性摘要信息的自定义中添加,才能链接到标题栏中。6)设置材料明细表定位点在FeatureManager设计树中展开“图纸格式1”,右击“材料明细表定位点1”,从快捷菜单中选择【设定定位点A】命令,选择标题栏右上角点,如图10-21所示。此时图纸由编辑图纸格式状态自动切换到编辑图纸状态。工程图1比例1: 1SPRPSHEETA注解T件数SPAPSHEET摄白图纸1RPSHEETPAPSHEET:材料】白图纸格式1材料明细表定位点1图10-21设定明细表定位点7)保存图纸格式206
206 建立“件数”、“材料”、“图号”、“制图”等属性链接。链接属性后的标题栏如图 10-20 所示。 图 10-19 在编辑清单和摘要信息中添加重量属性 图 10-20 链接了属性的标题栏 注意:上述所链接的零件属性必须在零件模型文件属性摘要信息的自定义中添加,才能链接 到标题栏中。 6)设置材料明细表定位点 在 FeatureManager 设计树中展开“图纸格式 1”,右击“材料明细表定位点 1”,从快捷 菜单中选择【设定定位点 A】命令,选择标题栏右上角点,如图 10-21 所示。此时图纸由编 辑图纸格式状态自动切换到编辑图纸状态。 图 10-21 设定明细表定位点 7)保存图纸格式